3rd Party dependencies

Discussions related to SoftPro Select user interface development.

Moderator: Phil Barton

Post Reply
turp1twin
Posts: 13
Joined: Tue Aug 20, 2019 4:32 pm

3rd Party dependencies

Post by turp1twin » Mon Aug 26, 2019 5:31 pm

Another quick question, I haven't managed to find an answer for.. I have a couple of 3rd party dependencies that I install into my Shell package application via NuGet. Everything builds great, but when I run the app locally (with "start" from VS2015) I get the dreaded "Could not load file or assembly..." error. The DLL's are not in the SoftPro/Select app directory. As these are referenced dependencies, should they automatically get copied over, or do I have to do this manually? Thanks!

Jeff

turp1twin
Posts: 13
Joined: Tue Aug 20, 2019 4:32 pm

Re: 3rd Party dependencies

Post by turp1twin » Tue Aug 27, 2019 11:44 am

Building on my previous question, I am building a shell package for SoftPro Select Client 4.3.15.1. This version of the SoftPro client apparently has a dependency on Newtonsoft.Json.dll version 10.0.2. I have a 3rd party dependency (auth0.oidcClient.Wpf) that has a transitive dependency on Newtonsoft.Json.dll version 11.0.2 or greater.. I have tried everything but still get the dreaded "Could not load file or assembly". Have you guys encountered this and if so, how were you able to resolve it... Thanks!

Jeff

turp1twin
Posts: 13
Joined: Tue Aug 20, 2019 4:32 pm

Re: 3rd Party dependencies

Post by turp1twin » Tue Aug 27, 2019 12:09 pm

So I seem to have gotten past the version mismatch. I had to update the Select.exe.config file, updating the "runtime" element as follows:

<runtime>
<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
<dependentAssembly>
<assemblyIdentity name="Newtonsoft.Json" publicKeyToken="30ad4fe6b2a6aeed" culture="neutral" />
<bindingRedirect oldVersion="11.0.0.0-11.0.2.0" newVersion="11.0.0.0" />
<codeBase version="11.0.0.0" href="Newtonsoft.Json-11.0.2.dll"/>
</dependentAssembly>
</assemblyBinding>
</runtime>

Post Reply