Developing for version 4.5+

Discussions related to custom development with Select.
Post Reply
chris.brady
Posts: 105
Joined: Wed Oct 17, 2012 4:20 pm

Developing for version 4.5+

Post by chris.brady » Fri Feb 22, 2019 10:28 am

I don't see anything in the current SDK, so here it goes...

Starting in 4.5, it appears that each user requires their own Select installation. Since we're in a terminal server environment, how do we develop for that? The client install no longer sits in the program files folder, so how do we deal with developing, registering, and deploying Shell packages?

Additionally, after upgrading one of our development workstations to 4.5 and installing the SDK, shell projects developed in 4.3 will no longer load (error sample below). We haven't had this issue before when upgrading versions. Is there documentation for how to handle migrating projects to this newer version?
C:\TFS\SoftPro Shell Packages\ApplyDocuments\ApplyDocuments\ApplyDocuments.csproj : error : The imported project "C:\Program Files (x86)\MSBuild\SoftPro\Select\SoftPro.Select.Sdk.targets" was not found. Confirm that the path in the <Import> declaration is correct, and that the file exists on disk. C:\TFS\SoftPro Shell Packages\ApplyDocuments\ApplyDocuments\ApplyDocuments.csproj

Post Reply