Failed to communicate with the server

Discussions related to SoftPro Select Server development.

Moderator: Phil Barton

Post Reply
geggold
Posts: 3
Joined: Fri Mar 16, 2012 1:49 pm

Failed to communicate with the server

Post by geggold » Fri Mar 16, 2012 2:12 pm

I'm getting the following error:

Failed to communicate with the server. Check your network settings and ensure the server is running.

The error occurs on the line highlighted below. The URI has been confirmed by the client and they believe that the firewall settings are correct, but I have no direct control over that.

// Create the server object. Note the use of the constant to define custom login.
NetworkCredential credential = new NetworkCredential(username, pwd, SoftPro.ClientModel.Constants.ServerDomain);
SelectServer server = new SelectServer(null, new Uri("http://ptmail.premier-Title.com:8081"), credential);

//SelectServer server = new SelectServer(null, new Uri(@"http://ptmail.premier-Title.com:8081"));

// Create the order tracking client
SoftPro.OrderTracking.Client.OrderTracking ot = server.GetService<SoftPro.OrderTracking.Client.OrderTracking>();

Randy Mellow

Re: Failed to communicate with the server

Post by Randy Mellow » Fri Mar 16, 2012 3:39 pm

The first thing to ensure is that the Select server instance referenced by the URI is actually running.
What happens if you type that URI into a web browser? Does it recognize a service on the other end (whether it's available or not, e.g. 503 error) or is it unable to find anything?
There may be information logged in the event viewer on your machine that could provide more detailed information as to why the communication isn't happening.
Select uses WCF to communicate between tiers of the system and WCF relies on MSDTC. DTC has to be enabled and allowed through the firewall. Can you connect with the Select client from your machine?

geggold
Posts: 3
Joined: Fri Mar 16, 2012 1:49 pm

Re: Failed to communicate with the server

Post by geggold » Mon Mar 19, 2012 11:25 am

I got no response using a browser so I tried TELNET next:

telnet ptmail.premier-Title.com 8081

and I got

Connecting To ptmail.premier-Title.com...Could not open connection to the host, on port 8081: Connect failed

my assumption is that if the firewall settings at the client were correct, I would have gotten some sort of connection, right?

Randy Mellow

Re: Failed to communicate with the server

Post by Randy Mellow » Mon Mar 19, 2012 11:51 am

The "connection failed" message is too general. It doesn't supply enough information to determine if the communication is blocked or if there's no service at the other end.

geggold
Posts: 3
Joined: Fri Mar 16, 2012 1:49 pm

Re: Failed to communicate with the server

Post by geggold » Wed Mar 21, 2012 2:59 pm

Question. Assuming that the firewall IS set correctly and there IS service at the other end, would I get some sort of "positive" reply using TELNET? I'm expecting that I would connect even though I couldn't do much. I'd also expect to receive some sort of response using a browser, correct?

SoftPro tech support confirms that the service is up and running correctly at the client's site and the client's IT person is working on the firewall settings.

Randy Mellow

Re: Failed to communicate with the server

Post by Randy Mellow » Wed Mar 21, 2012 4:15 pm

I don't know what you might get as a response from telnet but you would, most likely, get a 503 response via HTTP. That would indicate that the service is available even though it isn't accessibly via the browser.

Post Reply