Notification Registration not working

Discussions related to SoftPro Select Server development.

Moderator: Phil Barton

Post Reply
robertoedwards
Posts: 23
Joined: Wed Feb 27, 2013 8:07 pm

Notification Registration not working

Post by robertoedwards » Wed Oct 26, 2016 1:04 pm

I have taken the soap11 example from the SDK doc and placed it in an XML file:

<?xml version="1.0" encoding="utf-8" ?>
<Subscriptions xmlns="http://schemas.softprocorp.com/select/n ... ng/2008/04">
<Subscription eventid="C4EDBD4F-F11D-4C48-BE08-8C105181F5C9">
<Filter />
<Transform />
<DeliveryKind>soap11</DeliveryKind>
<DeliveryAddress>http://service.newventureescrow.com:909 ... eryAddress>
<Guaranteed>true</Guaranteed>
</Subscription>
</Subscriptions>

Except for the DeliveryAddress is is identical to the example. Yet when I try to register it using sps.exe, I get:

The 'eventid' attribute is not declared.
The 'eventid' attribute is not declared.
at SoftPro.Select.CommandLine.Commands.SubscribeCommand.<Run>b__2(Object sender, ValidationEventArgs e)
at System.Xml.Schema.XmlSchemaValidator.SendValidationEvent(String code, String arg)
at System.Xml.Schema.XmlSchemaValidator.ValidateAttribute(String lName, String ns, XmlValueGetter attributeValueGetter, String attributeStringValue, XmlSchemaInfo schemaInfo)
at System.Xml.XsdValidatingReader.ValidateAttributes()
at System.Xml.XsdValidatingReader.ProcessElementEvent()
at System.Xml.XsdValidatingReader.Read()
at System.Xml.Linq.XContainer.ReadContentFrom(XmlReader r)
at System.Xml.Linq.XContainer.ReadContentFrom(XmlReader r, LoadOptions o)
at System.Xml.Linq.XDocument.Load(XmlReader reader, LoadOptions options)
at SoftPro.Select.CommandLine.Commands.SubscribeCommand.Run()
at SoftPro.Select.CommandLine.Program.RunCommand(String[] args)

What is missing from my registration XML? I am assuming that's where the problem is.

BobRichards
Posts: 1006
Joined: Wed Jan 15, 2014 3:50 pm
Location: Raleigh, NC
Contact:

Re: Notification Registration not working

Post by BobRichards » Thu Oct 27, 2016 11:21 am

Sorry. We had typos in the SDK and it will be fixed. Also, do not add the <?xml ...> element at the top of the file since it will cause the subscription to fail (with an error message). The corrected version of your subscription is:

Code: Select all

<Subscriptions xmlns="http://schemas.softprocorp.com/select/notifications/eventing/2008/04">
	<Subscription event="C4EDBD4F-F11D-4C48-BE08-8C105181F5C9">
		<Filter />
		<Transform />
		<Delivery>soap11</Delivery>
		<Address>http://service.newventureescrow.com:9090/EscrowDataService.asmx/NotifyEvent</Address>
		<Guaranteed>true</Guaranteed>
	</Subscription>
</Subscriptions>
Bob Richards, Software Developer, SoftPro

robertoedwards
Posts: 23
Joined: Wed Feb 27, 2013 8:07 pm

Re: Notification Registration not working

Post by robertoedwards » Fri Oct 28, 2016 4:48 pm

Yep, that was it. Thanks.

Post Reply